Discussions for Apple IIgs Programming and other fun stuff. // Infinitum!

Home » Apple II Programming » General » Merlin 8 assembler problems with saving
Merlin 8 assembler problems with saving [message #30] Thu, 02 October 2014 13:40 Go to next message
jdmoser is currently offline  jdmoser
Messages: 1
Registered: September 2014
I'm a total assembly newbie, but I'm learning fine enough. My favorite assembler so far is Merlin, and I find the documentation is pretty easy to follow and understand.

However, I'm having trouble in the area of saving source and object files. Merlin just flat out doesn't seem to respond. I'll try to save, and then do a catalog, and nothing appears on the diskette. I've tried a few different versions, and I've tried them both on emulation and real Apple II hardware, and I keep running into the same problem: I can't save source or object files to diskette.

I'm hoping there might be somebody around here that has experience with Merlin and might have a possible solution Smile

If not, what other assemblers would you recommend to a newbie? I've tried the one included in the Applesoft Tool Kit, and I've tried LISA... and neither one of them feel quite as safe and fun to use as Merlin. It really does seem to be the best aside from this one problem.
Re: Merlin 8 assembler problems with saving [message #33 is a reply to message #30] Sun, 05 October 2014 02:19 Go to previous messageGo to next message
Oz is currently offline  Oz
Messages: 21
Registered: October 2014
Location: France

Do you use Merlin 16+ on an Apple IIgs (or Emulator) or do you use Merlin 8 on an Apple IIe/c ?

Merlin let you Save your source file (.s), you can assemble them (usually it performs both Save + Assemble). But if you want an object code to be created on disk, you have to use the Link command. So usually, we go directly to command LINK that ask for a Save (say Yes) and Assemble + Link the object code as a usable file.



[Updated on: Sun, 05 October 2014 02:20]

Report message to a moderator

Re: Merlin 8 assembler problems with saving [message #56 is a reply to message #33] Wed, 08 October 2014 14:58 Go to previous message
Dagen is currently offline  Dagen
Messages: 27
Registered: August 2014
Location: United States

For Merlin 16+, it will save the file in the current directory as noted on the main menu screen, unless a full path is specified. You may want to change this prefex to the disk/folder you'd like to use, then try to edit and save.

From the main menu type "D" for disk command and enter "prefix /myprefix" to change to a volume called "myprefix". Obviously, change that to the name of your volume. Then hit "E" to enter the editor and to save it, simply hit OpenApple-S and type in the name to save as. Then exit the editor and try to catalog your volume. Perhaps that helps?
Next Topic: Assemblers
Goto Forum:

Current Time: Wed Mar 20 18:19:06 MDT 2019

Total time taken to generate the page: 0.00682 seconds